Eventghost locks up after first command sent from Eventphone

Forum to discuss EventPhone iPhone/iPod Touch client for EventGhost

Eventghost locks up after first command sent from Eventphone

Postby mikaelc » Mon Dec 26, 2011 3:58 pm

Hi,
using the latest eventphone together with latest Eventghost, connection works fine but when I try to use any buttons eventghost freezes and needs a restart.
I'm trying to use it with USB-UIRT and I've removed most plugins. Any ideas where to start looking? First command works, on the second one (even if I use the same button) it freezes...

-mikaelc
mikaelc
 
Posts: 2
Joined: Mon Dec 26, 2011 3:42 pm

Re: Eventghost locks up after first command sent from Eventphone

Postby Melloware » Mon Dec 26, 2011 6:54 pm

What exact version of EventGhost server are you using? The latest release from here:

http://www.eventghost.org/downloads/

I can't imagine what would be freezing up as the code has not changed in a couple of years unless something broke?
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Eventghost locks up after first command sent from Eventphone

Postby mikaelc » Tue Dec 27, 2011 2:45 pm

Hi,

Yes, it's the latest version. Installed on win7 32bit along with telldus software for tellstick but that's more or less all that computer does. If I press the "play" symbol it executes a macro I've tied to it but if I press it a second time, Eventghost hangs (not responding)...

Eventghost itself can without problems execute the macro several times in a row and scheduled, that's why it puzles me..

-mikaelc
mikaelc
 
Posts: 2
Joined: Mon Dec 26, 2011 3:42 pm

Re: Eventghost locks up after first command sent from Eventphone

Postby Melloware » Tue Dec 27, 2011 2:56 pm

OK try something else. Press and EventPhone key that is mapped to some simple EventGhost event, as simple as you can get.

I wonder if it calling from EventPhone plugin to your Telldus plugin that there is a threading issue locking it up.

To test this have EventPhone do something really simple from a remote button.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Eventghost locks up after first command sent from Eventphone

Postby urdumania.com » Mon Feb 27, 2012 8:04 am

Hi

I am trying to get EventGhost working with the built in ir receiver in the Asrock ION 330HT and am failing miserably.

I am running Windows 7 Ultimate and EventGhost 0.3.7.r1194.

On first installation when pressing the remote buttons it moves the selection in EventGhost but no events appear in the log. After installing the MCE and disabling HID the remote no longer moves anything in EventGhost but there is still nothing in the event log. I have also tried the alternative Vista/Win7 plugin with the same result.

Device manager reports the ir receiver as a Nuvoton W836x7HG CIR Device and the remote is an MCE remote.

Does EventGhost support this receiver or am I doing something wrong?

Thanks
MrC
urdumania.com
 
Posts: 1
Joined: Mon Feb 27, 2012 8:03 am

Re: Eventghost locks up after first command sent from Eventphone

Postby Melloware » Mon Feb 27, 2012 7:35 pm

You want the EVentGhost forums not these forums. These forums are for hte iPhone app.

See these forums:

http://www.eventghost.org/forum/
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to EventPhone for EventGhost

Who is online

Users browsing this forum: No registered users and 1 guest