X10 Commander 1.9.1

Forum to discuss X10 Commander iPhone/iPod/iPad/Android client for X10 Devices

X10 Commander 1.9.1

Postby Melloware » Thu Nov 04, 2010 3:15 pm

Welcome to the X10 Commander forum for iPhone/iPod/iPad/Android. Feel free to post any bugs, comments, suggestions here!

I promise to make any bug fixes as fast as I can and suggestions for improvement are always welcome!

http://melloware.com/products/x10commander/

Version 1.91 Posted to the AppStore 11/04/2010
--------------------------------------------------------
- Updated Server EXE to send device status for CM15 and CM19
- Updated iPhone and Android to handle the display of the updated device status

Version 1.90 Posted to the AppStore 10/19/2010
--------------------------------------------------------
- When the iPhone is rotated 180 degrees the screen flips with it.

Version 1.82 Posted to the AppStore 09/25/2010
--------------------------------------------------------
- Google Android version released on the Android Market!
- Fixed some minor bugs introduced with OS 4 compatibility

Version 1.81 Posted to the AppStore 09/05/2010
--------------------------------------------------------
- Recompiled to make it backward compatible with OS 3.0+ (OS3 and OS4)

Version 1.8 Posted to the AppStore 08/24/2010
--------------------------------------------------------
- Fixed OS 4.0 bugs and compiled for OS 4.0

Version 1.7 Posted to the AppStore 02/12/2010
--------------------------------------------------------
- Fixed bug with after sleep the device selected crashed if you tried to turn it on or off

Version 1.6 Posted to the AppStore 12/09/2009
--------------------------------------------------------
- Added ability to use UTF encoded device names
- Compiled under OS 3.0
- Added new Reachability code to better handle checking for a connection before trying to connect
- Fixed bug with disabling buttons when not active so they can't be pressed
- Server Messages ON/OFF now removes text completely.

Version 1.5 Posted to the AppStore 08/08/2009
--------------------------------------------------------
- Fix crashing if you pressed an ON OFF button before successfully connecting
- When waking from sleep or locked and reconnecting it puts you on the last device you had selected before sleep.


Version 1.4 Posted to the AppStore 07/24/2009
--------------------------------------------------------
- Added automatic reconnect when waking from sleep or locked state
- Switched location of ON and OFF buttons to align with Bright and Dim
- Fixed memory leak

Version 1.3 Posted to the AppStore 12/11/2008
--------------------------------------------------------
- Changed icon name to X10 so no more ... in name
- IMPORTANT: Settings now has a Password which must match the server EXE password so please download the latest EXE.


Version 1.2 Posted to the AppStore 11/08/2008
--------------------------------------------------------
- Now works over Edge and 3G Connection!

Version 1.1 Posted to the AppStore 11/03/2008
--------------------------------------------------------
- Added ability to brighten lights and not just dim them
- Timeout is now 4 seconds instead of 1 second if can't find server
- minor tweaks and improvements
User avatar
Melloware
Site Admin
 
Posts: 11055
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: X10 Commander 1.9.1

Postby Robert » Tue Jan 04, 2011 8:14 am

Until yesterday X10 Commander was working flawlessly for about a year. Yesterday I updated my iPhone client to the latest version of X10 Commander: Ver. 1.9.1 and at that time I did not download the EXE to the server. When I tried running the program I received an error message of: "Passwords do not match". In my haste I changed the password to what I thought it shouldve been on my iPhone thinking it didn't upgrade properly. Since then I downloaded my server executable to version 1.9.1 from 1.6.1.111. I now do not know what my iPhone password should be to match the server. I am running Windows XP service pack 3 on my PC and have a 3G iPhone OS of 4.2.1. How can I get the passwords to match.
Robert
 
Posts: 9
Joined: Mon Jan 03, 2011 1:01 pm

Re: X10 Commander 1.9.1

Postby Melloware » Tue Jan 04, 2011 8:15 am

Robert wrote:Until yesterday X10 Commander was working flawlessly for about a year. Yesterday I updated my iPhone client to the latest version of X10 Commander: Ver. 1.9.1 and at that time I did not download the EXE to the server. When I tried running the program I received an error message of: "Passwords do not match". In my haste I changed the password to what I thought it shouldve been on my iPhone thinking it didn't upgrade properly. Since then I downloaded my server executable to version 1.9.1 from 1.6.1.111. I now do not know what my iPhone password should be to match the server. I am running Windows XP service pack 3 on my PC and have a 3G iPhone OS of 4.2.1. How can I get the passwords to match.


Robert, Simply open the X10 Commander Server UI and change the password box right in the middle of the Screen.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11055
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to X10 Commander

Who is online

Users browsing this forum: No registered users and 1 guest

cron