[SOLVED] License expired after upgrade to Icecream sandwich

Forum to discuss Lightswitch/ZWave Commander iPhone/iPod/iPad/Android home automation application

[SOLVED] License expired after upgrade to Icecream sandwich

Postby gertk » Thu Apr 26, 2012 5:59 pm

My Lightswitch 2.4.4.0 says "license expired" (in my case in Dutch) after upgrade of my Samsung Galaxy 2 phone OS to Android 4.0.3. After some time it connects with the server and works as usual. I bought the license a few months ago and do not agree to pay for it on the same phone once more. Can i simply ignore the message, or will it prevent future updates ?

Gert Könemann,
Nijmegen
The Netherlands
gertk
 
Posts: 1
Joined: Thu Apr 26, 2012 5:46 pm

Re: License expired after upgrade to Icecream sandwich

Postby Melloware » Fri Apr 27, 2012 5:32 am

What happens is it checks the Google License servers to make sure you have a valid license. Sometimes if it can't reach that server you will get that message but the next time it can reach Google License servers it validates your install and that message goes away.

This happens sometimes if you are in airplane mode or don't have a WIFI connection or if the Google License server was slow in responding.

It should always work once license and once in a while it contacts Google to make sure your license is still valid.

You can read more about it here:

http://developer.android.com/guide/mark ... index.html
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11044
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to Lightswitch/ZWave Commander

Who is online

Users browsing this forum: No registered users and 1 guest

cron