[FIXED] App seems to exit out without logging in

Forum to discuss the BlueSocket Authenticator for iPhone/iPod Touch

[FIXED] App seems to exit out without logging in

Postby keitaisamurai » Fri Sep 19, 2008 8:01 am

I am having some trouble getting the Bluesocket authenticator to work.

I have entered my user name and password under Settings->BlueSocket (and re-entered them a few times to make sure I input it correctly). I also have the "AutoClose" option set to off in Settings->BlueSocket.

When I start the BlueSocket Authenticator app, the screen turns all black (except for the time, etc at the top) for about three seconds, then the brightness dims for about 2 seconds, and finally the app exits out. After this, when I go to Safari, and try to go to google.com, I am directed back to our BlueSocket login page.

If instead I login via our Bluesocket login page through Safari, then exit Safari, and start the BlueSocket app, I immediately get the green checkmark.

Any help would be appreciated.

I will PM you with our bluesocket login URL and page source.

Thanks.
keitaisamurai
 
Posts: 2
Joined: Fri Sep 19, 2008 6:52 am

Re: App seems to exit out without logging in

Postby Melloware » Fri Sep 19, 2008 8:13 am

Check out this Post....its because your university or company is using an invalid certificate. So instead of being redirected BlueSocket Authenticator is receiving a certificate error. This user posted his solution.

viewtopic.php?f=9&t=6345
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby keitaisamurai » Mon Sep 22, 2008 3:29 pm

So, I've done a little more investigation, but still can't get it to work.

The problem I'm having is with the certificate installation on the iPhone. Failure to get a valid certificate chain is making BlueSocket Authenticator not work.

If I open my institution's Bluesocket log-in page from my PC using Firefox, I get a secure (https://) connection. Double clicking on the lock icon (bottom right), that will bring up the "Page Info" dialog with the security tab selected. From there I can click on "View certificate" which brings up a "Certificate viewer" dialog, and finally clicking the details tab I can see the complete hierarchy for the certificates. In my case there are three certificates in the hierarchy and I can select and export each one in turn, getting three different .crt files. I then emailed these files to myself, opened the email on the iphone and clicked on the attachments to install them, making sure I installed the Root CA first, then the Controller CA, and finally the Site certificate.

After doing all that, all three certificates still indicate "unsigned" on the iphone and when I go to the bluesocket log-in page using Safari on the iphone, I still get the "invalid certificate" error.

Has anyone been able to get a certificate chain installed and working?

The URL for our log-in page is https://134.192.121.13/

I am at a loss as to how to get the certificate chain installed correctly...
keitaisamurai
 
Posts: 2
Joined: Fri Sep 19, 2008 6:52 am

Re: App seems to exit out without logging in

Postby Melloware » Mon Sep 22, 2008 3:33 pm

I have forwarded this post to another user who is working on the same "3 certificate" problem. I have other users like lordpookdai and Chicane-UK who installed their Universities certificate and BlueSocket authenticator started working. Hopefully my other user who has the same problem as you with 3 certs will narrow it down and figure it out. Stay tuned....
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby Bazzini » Fri Sep 26, 2008 3:50 pm

Hey,

I am also having the same problem this user is having. I have tried installing the certificates and it still says it is not unsigned and I get the 'certificate invalid message. Just like he mentioned, when I launchthe app the screen turns all black (except for the time, etc at the top) for about three seconds, then the brightness dims for about 2 seconds, and finally the app exits out.

Is there a work around for this in the pipeline?
Bazzini
 
Posts: 1
Joined: Fri Sep 26, 2008 1:40 pm

Re: App seems to exit out without logging in

Postby Melloware » Fri Sep 26, 2008 4:17 pm

Bazzini wrote:Hey,

I am also having the same problem this user is having. I have tried installing the certificates and it still says it is not unsigned and I get the 'certificate invalid message. Just like he mentioned, when I launchthe app the screen turns all black (except for the time, etc at the top) for about three seconds, then the brightness dims for about 2 seconds, and finally the app exits out.

Is there a work around for this in the pipeline?


Well it seems some people are able to install a proper certificate and BlueSocket works fine after that. Others are reporting that same problem you are having which is the cert is still not valid. Version 1.2 at least stops the crashing but I am guessing it will give you a "Certificate is Untrusted" and the REd X. 1.2 should be out any day now on the AppStore. Give it a try when it comes out...
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby Melloware » Mon Nov 03, 2008 8:20 am

I think we have a workaround in the mix. We will be BETA testing it in the next day or two.

viewtopic.php?f=9&t=6517
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby jeromelove » Mon Nov 03, 2008 1:29 pm

I'm having the same problem at the University of Georgia. I have installed the v1.2 of the app and when I launch it the screen goes black then the app closes after a few minutes without logging in to the network. This is with the Universities certificate installed on my 2 gen Ipod Touch. I can go to Settings, of the Ipod, then General, then Profile, and see the certificate. It is unsigned but is valid and current and issued by bluesocket.

I'd love of this to work since I bought the app. and it will save much typing. Any help would be greatly appreciated. Thanks, J
jeromelove
 
Posts: 3
Joined: Mon Nov 03, 2008 1:16 pm

Re: App seems to exit out without logging in

Postby Melloware » Mon Nov 03, 2008 1:33 pm

jeromelove,

If you download an application called Ad Hoc Helper for your phone it will email me your 40 digit UDID so I can send you the BETA also to try at the University of Georgia.

More testers the merrier as this invalid certificate bug has been a huge pain in my side. I can't test it because the company I work for has a valid HTTPS SSL connection so it works for me everytime.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby jeromelove » Mon Nov 03, 2008 1:38 pm

Thanks for the quick reply. I'll get that downloaded now. J
jeromelove
 
Posts: 3
Joined: Mon Nov 03, 2008 1:16 pm

Re: App seems to exit out without logging in

Postby jeromelove » Mon Nov 03, 2008 1:44 pm

I sent the email to info@melloware.com; is this correct?

J
jeromelove
 
Posts: 3
Joined: Mon Nov 03, 2008 1:16 pm

Re: App seems to exit out without logging in

Postby Melloware » Mon Nov 03, 2008 1:48 pm

jeromelove wrote:I sent the email to info@melloware.com; is this correct?

J


I got it!

Can you do me a favor and run some other tests with 1.2? I will ask you to run them again with 1.3...

1. On an Edge or 3G connection try and hit BlueSocket Authenticator. You should get a Red X with WIFI connection not found.

2. On a valid wireless network like your home network hit BlueSocket Authenticator. You should get a green X with a success message (since you are on a valid connection I hit http://www.google.com and if a response is returned you are already connected.)
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: App seems to exit out without logging in

Postby Melloware » Tue Nov 04, 2008 12:36 pm

jeromelove has confirmed the suggested fix has fixed his problem at his university. I will be uploading version 1.3 to the AppStore tonight so it should hit in about 7 business days if Apple is on course.

i am marking this thread FIXED!!! (Finally). :)
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11016
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to BlueSocket Authenticator (closed)

Who is online

Users browsing this forum: No registered users and 1 guest