Issue with Firecracker

Forum to discuss X10 Commander iPhone/iPod/iPad/Android client for X10 Devices

Issue with Firecracker

Postby vivet » Sun Jun 05, 2016 3:42 pm

Hi

I have tried for a while to get X10 commander to work, without success.
I am using an USB-to-Serial adapter with Firecracker CM17A on my PC. I have a TM13 Transceiver module and several LM12 lamp modules.
I know that there can be some issues using the USB adapter, though i am not sure that is actually the issue. From the logs it seems that its sending the signal to the firecracker, though the lights doesn't switch on / off.
The logs have no errors, though show a warning, which i don't fully understand; "X10 C0M object not found". What does it mean, and is it relevant?

Any help or tips is appreciated.

Log:
05-06-2016 22:13:44 [ INFO] INIT X10Commander [STARTING]
05-06-2016 22:13:44 [ INFO] INIT --------------------------------------------------------------------------------------------------
05-06-2016 22:13:44 [ INFO] INIT X10Commander Version: 1.9.8.195
05-06-2016 22:13:44 [ INFO] INIT System : Windows 8 Workstation
05-06-2016 22:13:44 [ INFO] INIT IP Address: 192.168.1.50
05-06-2016 22:13:44 [ INFO] INIT Processor : Intel(R) Core(TM) i3-4130 CPU @ 3.40GHz
05-06-2016 22:13:44 [ INFO] INIT Display : 1920x1080 pixels, 32 bpp
05-06-2016 22:13:44 [ INFO] INIT --------------------------------------------------------------------------------------------------
05-06-2016 22:13:44 [ INFO] INIT Using Firecracker CM17
05-06-2016 22:13:44 [ INFO] INIT TCP Socket = 6003
05-06-2016 22:13:44 [ INFO] INIT HTTP Socket = 8086
05-06-2016 22:13:44 [ INFO] INIT Max Connections = 3
05-06-2016 22:13:44 [ INFO] INIT MinimizeOnStartup = 0
05-06-2016 22:13:44 [ INFO] INIT DimmingAccuracyEnabled = 0
05-06-2016 22:13:44 [ INFO] INIT DefaultDimLevel = 12
05-06-2016 22:13:44 [ INFO] INIT Using Firecracker CM17
05-06-2016 22:13:44 [ INFO] INIT Firecracker Port = COM3
05-06-2016 22:13:44 [ WARN] INIT X10 COM Object not found
05-06-2016 22:13:44 [ INFO] INIT X10Commander [STARTED]
05-06-2016 22:14:42 [DEBUG] Opening LogFile...
05-06-2016 22:14:42 [DEBUG] ExecuteExternalApplication C:\Windows\notepad.exe C:\Users\MediaUser\AppData\Roaming\X10Commander\X10 Commander.log
05-06-2016 22:31:10 [DEBUG] Opening LogFile...
05-06-2016 22:31:10 [DEBUG] ExecuteExternalApplication C:\Windows\notepad.exe C:\Users\MediaUser\AppData\Roaming\X10Commander\X10 Commander.log
05-06-2016 22:31:19 [ INFO] MENUExecuting Menu Option 3
05-06-2016 22:31:19 [ INFO] MENUTurning device A3 OFF
05-06-2016 22:31:19 [ INFO] MENUExecuting CM17 Command
05-06-2016 22:31:19 [ INFO] MENUCM17 Result Code = 0
05-06-2016 22:31:25 [DEBUG] Opening LogFile...
05-06-2016 22:31:25 [DEBUG] ExecuteExternalApplication C:\Windows\notepad.exe C:\Users\MediaUser\AppData\Roaming\X10Commander\X10 Commander.log
vivet
 
Posts: 3
Joined: Sun Jun 05, 2016 3:20 pm

Re: Issue with Firecracker

Postby Melloware » Mon Jun 06, 2016 10:01 am

You are right it appears it is speaking to your Firecracker on COM3 but not receiving any errors. So it thinks it called your firecracker successfully it just did not actually do anything.

We have seen issues in the past with the USB-To-SERIAL connections not acting like a true Serial connection even though the API thinks it is.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11044
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Issue with Firecracker

Postby vivet » Mon Jun 13, 2016 5:35 am

Okay thanks for the confirmation.
I will try buy a simple x10 remote and see if I can get the setup working directly.

...by the way I tried 2 different usb-to-serial cables. Same result.
vivet
 
Posts: 3
Joined: Sun Jun 05, 2016 3:20 pm

Re: Issue with Firecracker

Postby Melloware » Mon Jun 13, 2016 7:11 am

vivet wrote:Okay thanks for the confirmation.
I will try buy a simple x10 remote and see if I can get the setup working directly.

...by the way I tried 2 different usb-to-serial cables. Same result.


Yeah the code I use to speak to the serial port is almost 20 years old. And Serial is a dead technology so finding answers on it is almost impossible. Some people seem to have luck others do not.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11044
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Issue with Firecracker

Postby vivet » Sat Jul 02, 2016 6:54 am

Ok thanks for the assistance, and confirmation that i am not crazy :-)
I will find out something, or change the home automation technology.

You can close the subject.
vivet
 
Posts: 3
Joined: Sun Jun 05, 2016 3:20 pm


Return to X10 Commander

Who is online

Users browsing this forum: No registered users and 0 guests

cron