SOLUTION : Hauppauge RC6 receiver suddenly stops working

Feature Requests, Comments, Bugs, and Suggestions on the Intelliremote application.

SOLUTION : Hauppauge RC6 receiver suddenly stops working

Postby SiliconKid » Mon Dec 08, 2014 12:06 pm


In the process of getting my licensed copy of Intelliremote working on my HTPC today I ran into some very strange behaviour with my new Hauppage RC6 receiver which actually had me believing that I had broken it for a few hours before I realised what was actually going on.

I thought I would just post my experience and findings here along with the solution I found so others might benefit from this.

I had the RC6 receiver in question working perfectly on my main dev PC and I had done a test run of Intelliremote there and experimented with profiles etc. until I had everything perfect.

This morning I wanted to take the receiver downstairs to my lounge and connect it to my dedicated HTPC where it will stay permanently and then transfer all of my prep work and findings to the HTPC.

In the process of doing that I accidentally dropped the receiver on the floor after I unplugged it from the dev PC and I was immediately concerned that I might have damaged. It didn't look damaged, but it fell hard.

I took it downstairs, plugged it into a USB port, it was detected immediately, and I tried to test the remote in the USB HID test app. Nothing happened. The light on the receiver was blinking every time I pushed a remote button but the test app didn't register any button push or any HID codes at all.

I tried another USB port. Still nothing. Then another one. Still nothing.

Then I checked the device manager, and everything looked fine, the devices were all installed and correctly identified.

At that point I started to think I had broken it.

I then took it back upstairs and plugged it back into the dev PC and sure enough, nothing. Same issue. Detected fine, device manager fine, light blinks on receiver, but nothing registers. No HID codes received.

I tried 4 different USB ports on the dev PC too, all gave the same result.

At that point I was disgusted with myself and resigned myself to the fact that I had broken my brand new receiver like an idiot.

I actually went online and ordered another one !

But then hours later, I decided to have a look at it again.

I tried a few different USB ports and still nothing.

Then I went into device manager and checked all the related devices again and everything looked 100% correct.

Regardless, I decided to take a flying chance on a hunch and I manually uninstalled every device in Device Manager related to the Microsoft eHome receiver / transceiver.

I then right clicked on my computers name at the top of the device tree and clicked "Scan for hardware changes".

It found the receiver again and then spent about a minute re-installing all the sub devices.

I then went straight back into the USB HID tester app and .... IT WORKED !

The devices in device manager are EXACTLY the same as they were before, but now it worked.

So then I unplugged it, went back downstairs, plugged it back into the HTPC, and did the same thing in device manager.

The HTPC asked me to reboot, I let it.

Then I immediately ran the USB HID tester and ... IT WORKED !

I have absolutely NO idea why that was necessary on either of my Windows 7 (Ultimate and Professional) machines, but it was, and now the receiver works perfectly on both machines again.

Be warned, you may run into this and it is a pure software problem and even though the Windows Device Manager says all devices are installed correctly and working, THEY ARE NOT !
Posts: 9
Joined: Fri Dec 05, 2014 4:25 am

Return to Intelliremote

Who is online

Users browsing this forum: No registered users and 2 guests