Problem and solution getting started with CM11A

Forum to discuss X10 Commander iPhone/iPod/iPad/Android client for X10 Devices

Problem and solution getting started with CM11A

Postby subnova » Fri Oct 15, 2010 11:53 pm

I had some problems getting the server set up with my CM11A, and thought I'd share the steps I took to resolve the problem.

The server software was properly configured, and I'd installed the X10 SDK. However, whenever I'd try to turn a light on or off from the context menu (right clicking on the icon in the system tray) the application would hang after the second command. The logs were uninformative:

Code: Select all
[10/15/2010 11:25:41 PM]  INIT >--------------------------------------------------------------------------------------------------
[10/15/2010 11:25:41 PM]  INIT >X10Commander Version:
[10/15/2010 11:25:41 PM]  INIT >System    : Windows XP Professional
[10/15/2010 11:25:41 PM]  INIT >IP Address:
[10/15/2010 11:25:41 PM]  INIT >Processor : Intel(R) Pentium(R) 4 CPU 3.00GHz
[10/15/2010 11:25:41 PM]  INIT >Display   : 1280x1024 pixels, 32 bpp
[10/15/2010 11:25:41 PM]  INIT >--------------------------------------------------------------------------------------------------
[10/15/2010 11:25:41 PM]  INIT >Initialize Registry Settings
[10/15/2010 11:25:41 PM]  INIT >TCP Socket = 6003
[10/15/2010 11:25:41 PM]  INIT >HTTP Socket = 8086
[10/15/2010 11:25:41 PM]  INIT >Max Connections = 3
[10/15/2010 11:25:41 PM]  INIT >MinimizeOnStartup = 0
[10/15/2010 11:25:41 PM]  INIT >DimmingAccuracyEnabled = 0
[10/15/2010 11:25:41 PM]  INIT >Using COM CM11/CM12
[10/15/2010 11:25:41 PM]  INIT >X10 COM Object found and being loaded
[10/15/2010 11:25:41 PM]  INIT >X10 COM v274
[10/15/2010 11:25:41 PM]  INIT >X10 DLL v3.0.0.274
[10/15/2010 11:25:41 PM]  INIT >X10 ActiveHome COM Object attempting to load...
[10/15/2010 11:25:41 PM]  INIT >X10Commander [STARTED]
[10/15/2010 11:25:54 PM]  MENU>Executing Menu Option 3
[10/15/2010 11:25:54 PM]  MENU>Turning device F3 ON
[10/15/2010 11:25:54 PM]  MENU>Executing CM11_CM12 Command
[10/15/2010 11:25:54 PM]X10 CM11>Send: F3
[10/15/2010 11:26:00 PM]  MENU>Executing Menu Option 2
[10/15/2010 11:26:00 PM]  MENU>Turning device F2 ON
[10/15/2010 11:26:00 PM]  MENU>Executing CM11_CM12 Command

I figured that I'd need to validate that the CM11A was even working, since I hadn't used it in years. I happened upon some X10 test software hiding on the Melloware servers, here:

When I fired it up and connected to the CM11A, it displayed a message saying, "device reports power fail. setting up device". Testing my X10 devices worked through the application.

Here's the strange part- when I closed the tester app and started X10 Commander back up, everything worked! I don't know what was initialized by the X10 tester program, but it must have been essential to the CM11A working properly.

Hope this helps the next guy using an old CM11A...
Posts: 1
Joined: Fri Oct 15, 2010 11:40 pm

Return to X10 Commander

Who is online

Users browsing this forum: No registered users and 1 guest