Empty Scenes in iOS app after ZVS upgrade?

Forum to discuss Lightswitch/ZWave Commander iPhone/iPod/iPad/Android home automation application

Empty Scenes in iOS app after ZVS upgrade?

Postby ctrlbreak » Wed Apr 17, 2013 4:06 pm

Hi There,

I've purchased the Lightswitch app for both iOS and Android. After a recent zVS upgrade on my home server, my "Scenes" list does not populate on my iPhone, yet works without issue on the Android? I've turned on debug logging in the ZVS plugin for Lightswitch, and I can see the plugin sending the scene list, but it never shows up on the iPhone. Also, I can hit the "Activate Scene" button and I can see the plugin will activate (what would be listed as) the first scene, but the listbox(? sorry, not iOS developer) never populates? Also, if I even touch the listbox on the iPhone, LIghtswitch immediately crashes.

I've tried removing and reinstalling Lightswitch on the iPhone, but the problem persists. I've also tried removing/reinstalling and restoring my Devices and Scenes in zVS, but that didn't make a difference (plus it still works on the Android).

Anyone have any idea?

Thanks,

Scott.
ctrlbreak
 
Posts: 3
Joined: Wed Apr 17, 2013 3:58 pm

Re: Empty Scenes in iOS app after ZVS upgrade?

Postby Melloware » Wed Apr 17, 2013 7:31 pm

OK it could possibly be how you named a scene that is tripping up the iOS Client when sending that list back. Can you past the ZVS log when it sends the responses back to the iOS device?
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11062
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Empty Scenes in iOS app after ZVS upgrade?

Postby ctrlbreak » Thu Apr 18, 2013 8:46 am

Sure thing! Thanks for the quick response. I'm still in the process of testing, and some detail from this log has been redacted.

2013-04-18 10:42:21,147 [XXXXXX-PC][Thread:1][INFO] zvs.Processor.zvsPlugin - Elec. Panel Meter Power changed from 3611.520 to 3613.500.
2013-04-18 10:42:28,428 [XXXXXX-PC][Thread:12][INFO] LightSwitchPlugin.LightSwitchPlugin - Client 192.0.2.1:36959 connected
2013-04-18 10:42:28,428 [XXXXXX-PC][Thread:12][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: LightSwitch zVirtualScenes Plug-in (Active Connections 1)
2013-04-18 10:42:28,600 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Received from [192.0.2.1:36959]: IPHONE
2013-04-18 10:42:28,678 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: COOKIE~39770
2013-04-18 10:42:28,709 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Received from [192.0.2.1:36959]: PASSWORD~XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
2013-04-18 10:42:28,725 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: VER~zVirtualScenes 6.1.20465.4839
2013-04-18 10:42:28,725 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Received [192.0.2.1:36959] User Authenticated
2013-04-18 10:42:28,740 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Received from [192.0.2.1:36959]: ALIST
2013-04-18 10:42:28,740 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Received [192.0.2.1:36959] User requested device, scene and group list
2013-04-18 10:42:28,756 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Appliance Switch 1~6~0~BinarySwitch
2013-04-18 10:42:28,756 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Bedroom Hallway~10~0~BinarySwitch
2013-04-18 10:42:28,756 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~BlackLight 1~7~0~BinarySwitch
2013-04-18 10:42:28,756 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~BlackLight 2~8~0~BinarySwitch
2013-04-18 10:42:28,772 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Elec. Panel Meter~3~0~Sensor
2013-04-18 10:42:28,772 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Lamp Dimmer 1~4~0~MultiLevelSwitch
2013-04-18 10:42:28,772 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Lamp Dimmer 2~5~0~MultiLevelSwitch
2013-04-18 10:42:28,772 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Lamp Dimmer 3~9~0~MultiLevelSwitch
2013-04-18 10:42:28,772 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: DEVICE~Server and Comms~2~0~BinarySwitch
2013-04-18 10:42:28,787 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: SCENE~Party~5~
2013-04-18 10:42:28,787 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: SCENE~Not Party~6~
2013-04-18 10:42:28,787 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: SCENE~Theatre Off~7~
2013-04-18 10:42:28,787 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Sent to [192.0.2.1:36959]: ENDLIST
2013-04-18 10:42:49,022 [XXXXXX-PC][Thread:6][INFO] LightSwitchPlugin.LightSwitchPlugin - Client 192.0.2.1:36959 disconnected
2013-04-18 10:42:51,162 [XXXXXX-PC][Thread:1][INFO] zvs.Processor.zvsPlugin - Elec. Panel Meter Power changed from 3613.500 to 3593.590
ctrlbreak
 
Posts: 3
Joined: Wed Apr 17, 2013 3:58 pm

Re: Empty Scenes in iOS app after ZVS upgrade?

Postby Melloware » Fri Apr 19, 2013 5:36 am

The only thing I see odd is it looks like there is an exta ~ for the scenes...

SCENE~Party~5~


should be...

SCENE~Party~5


Also this doesn't look right. Notice one

Other than that nothing looks out of the ordinary?
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11062
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: Empty Scenes in iOS app after ZVS upgrade?

Postby ctrlbreak » Fri Apr 19, 2013 8:13 am

Not really?

I can also check tonight after work to see if the plugin is communicating the scenes in a different format to the Android device?

Also, I may be mistaken, but I believe between restores of my Scene list in zVS, I tried Lightswitch on the iPhone with an *empty* scene list... and got the same behavior. Touching the scroll wheel in the Scene list caused the application to crash. :-S.
ctrlbreak
 
Posts: 3
Joined: Wed Apr 17, 2013 3:58 pm

Re: Empty Scenes in iOS app after ZVS upgrade?

Postby Melloware » Fri Apr 19, 2013 5:06 pm

Hmmm that is strange I have no one else reporting it. Can you try it with my free Zwave COmmander server EXE?

I just tested right now and it is working fine with Scenes which makes me think it might be a zVS bug?
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11062
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to Lightswitch/ZWave Commander

Who is online

Users browsing this forum: No registered users and 1 guest