[SOLVED] IPhone OS 4.0- Compatible?

Forum to discuss Lightswitch/ZWave Commander iPhone/iPod/iPad/Android home automation application

[SOLVED] IPhone OS 4.0- Compatible?

Postby MinaM1 » Wed Jun 23, 2010 8:44 pm

Is ZWave Commander compatiable with iPhone OS 4.0?
MinaM1
 
Posts: 7
Joined: Tue May 25, 2010 4:31 pm

Re: IPhone OS 4.0- Compatible?

Postby Melloware » Thu Jun 24, 2010 5:50 am

I haven't tested it myself yet but I haven't heard any reports to the contrary. I have been hesitant to upgrade my iPhone 3G since OS 4.0 doesn't support all its features only on the 3GS and the new 4G phones.

My wife installed it on her 3G I will let you know the results, I will have her run Zwave Commander.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11096
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: IPhone OS 4.0- Compatible?

Postby MinaM1 » Thu Jun 24, 2010 11:45 am

As of today, with the new 4.0 OS, no matter what I do I cannot connect to the ZWave Server. Let me know if it is just me or if it is the software.

Thanks!
Last edited by MinaM1 on Fri Jun 25, 2010 1:16 am, edited 1 time in total.
MinaM1
 
Posts: 7
Joined: Tue May 25, 2010 4:31 pm

Re: IPhone OS 4.0- Compatible?

Postby Melloware » Thu Jun 24, 2010 11:50 am

I just tried it on my wife's OS 4.0 and it worked flawlessly. Exactly the way it had in OS 3.

The only thing I had to do was make sure in the settings the IP Address and Password were set properly.

Are you sure you aren't connected to a wrong WIFI network on your OS4 or anything weird like that?
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11096
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: IPhone OS 4.0- Compatible?

Postby MinaM1 » Fri Jun 25, 2010 1:15 am

All fixed! I toggled the port from 6004 to 6000 and back to 6004. Then I erased the IP and re-entered it. For some reason that fixed it even though nothing changed.
MinaM1
 
Posts: 7
Joined: Tue May 25, 2010 4:31 pm

Re: IPhone OS 4.0- Compatible?

Postby Melloware » Fri Jun 25, 2010 5:57 am

MinaM1 wrote:All fixed! I toggled the port from 6004 to 6000 and back to 6004. Then I erased the IP and re-entered it. For some reason that fixed it even though nothing changed.


Another user just reported that same thing. It must be a change in the way OS 4 handles default values that it doesn't pick up the default 6003.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11096
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: [SOLVED] IPhone OS 4.0- Compatible?

Postby Melloware » Tue Aug 24, 2010 5:34 pm

Zwave Commander 2.3 has just been released to the AppStore which fixes this issue and has been recompiled for OS 4.0.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11096
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to Lightswitch/ZWave Commander

Who is online

Users browsing this forum: No registered users and 2 guests