ZWave Commander Not Showing Any Devices

Forum to discuss Lightswitch/ZWave Commander iPhone/iPod/iPad/Android home automation application

ZWave Commander Not Showing Any Devices

Postby Josh42 » Tue Mar 27, 2012 6:35 pm

Hello,

I just purchased LighSwitch and installed ZWave Commander. I currently have ThinkEssentials running version 2.5.4 with a ThinkStick.

ZWave Commander Shows no devices. I am running both programs as administrator (Windows 7 x64).

[Header]
2012-03-27 19:34:19,948 [INFO ] - Application [ZWave Commander] START
2012-03-27 19:34:19,962 [INFO ] - Initializing Preferences
2012-03-27 19:34:19,965 [INFO ] - Creating Preferences....
2012-03-27 19:34:19,966 [INFO ] - Deserializing XML file: C:\Users\blah blah blah\zwave-server\ZWaveCommander.exe.xml
2012-03-27 19:34:20,108 [INFO ] - Creating Preferences....
2012-03-27 19:34:20,219 [INFO ] - IP Address : blah blah
2012-03-27 19:34:20,219 [INFO ] - IP Address : blah blah
2012-03-27 19:34:20,219 [INFO ] - IP Address : 192.168.1.101
2012-03-27 19:34:20,219 [INFO ] - IP Address : blah blah
2012-03-27 19:34:20,222 [INFO ] - Creating NotificationIcon....
2012-03-27 19:34:20,222 [INFO ] - Initializing Menu...
2012-03-27 19:34:20,230 [INFO ] - mDNS Version: 333.10.0
2012-03-27 19:34:20,232 [INFO ] - ZWaveCommander 2.4.2.2
2012-03-27 19:34:20,237 [INFO ] - Starting HTTP Listener http://*:8084/...
2012-03-27 19:34:20,239 [ERROR] - HTTP Error: Access is denied
System.Net.HttpListenerException: Access is denied
at System.Net.HttpListener.AddAll()
at System.Net.HttpListener.Start()
at Melloware.ZWaveCommander.NotificationIcon..ctor()
2012-03-27 19:34:20,246 [INFO ] - Registering Growl Connector...
2012-03-27 19:34:20,292 [INFO ] - ControlThink.ZWave Version: 1.3.0.23
2012-03-27 19:34:20,292 [INFO ] - .NET Framework: 2.0.50727.5448
2012-03-27 19:34:20,293 [INFO ] - ZWave: Connecting...
2012-03-27 19:34:21,001 [INFO ] - Zwave Commander Published Bonjour Service: domain(local.) type(_zwavecomm._tcp.) name(Zwave Commander THEBEAST-JWK-PC)
2012-03-27 19:34:21,001 [INFO ] - Zwave Commander Published Bonjour Service: domain(local.) type(_lightswitch._tcp.) name(Lightswitch THEBEAST-JWK-PC)


Any ideas?
Josh42
 
Posts: 2
Joined: Tue Mar 27, 2012 6:27 pm

Re: ZWave Commander Not Showing Any Devices

Postby Melloware » Wed Mar 28, 2012 4:45 am

First, try right clicking on the EXE or ShorCut and choose Properties. Then under Compatability choose "Run As Administrator" and try again.

Paste the logs after you do that...

Also what firmware of the THinkStick are you running?

Here is what a proper log startup should look like...

Code: Select all
2012-03-08 22:38:03,709 [INFO ] - Application [ZWave Commander] START
2012-03-08 22:38:03,763 [INFO ] - Initializing Preferences
2012-03-08 22:38:03,763 [INFO ] - Creating Preferences....
2012-03-08 22:38:03,763 [INFO ] - Deserializing XML file: C:\Tools\zwave\ZWaveCommander.exe.xml
2012-03-08 22:38:04,392 [INFO ] - Creating Preferences....
2012-03-08 22:38:06,046 [INFO ] - IP Address : fe80::1f0:4cbe:7ce:a0da%10
2012-03-08 22:38:06,046 [INFO ] - IP Address : fe80::10b7:1560:3f57:fef4%12
2012-03-08 22:38:06,046 [INFO ] - IP Address : 192.168.1.11
2012-03-08 22:38:06,046 [INFO ] - Creating NotificationIcon....
2012-03-08 22:38:06,046 [INFO ] - Initializing Menu...
2012-03-08 22:38:06,064 [INFO ] - mDNS Version: 214.3.3
2012-03-08 22:38:06,064 [INFO ] - ZWaveCommander 2.4.2.2
2012-03-08 22:38:06,082 [INFO ] - Starting HTTP Listener http://*:8084/...
2012-03-08 22:38:06,100 [INFO ] - Registering Growl Connector...
2012-03-08 22:38:06,334 [INFO ] - ControlThink.ZWave Version: 1.3.0.23
2012-03-08 22:38:06,334 [INFO ] - .NET Framework: 2.0.50727.5448
2012-03-08 22:38:06,334 [INFO ] - ZWave: Connecting...
2012-03-08 22:38:06,963 [INFO ] - Zwave Commander Published Bonjour Service: domain(local.) type(_zwavecomm._tcp.) name(Zwave Commander VMWIN7-MELLO)
2012-03-08 22:38:06,963 [INFO ] - Zwave Commander Published Bonjour Service: domain(local.) type(_lightswitch._tcp.) name(Lightswitch VMWIN7-MELLO)
2012-03-08 22:38:14,421 [INFO ] - ZWave: Controller Connected! HomeId - 3668489476
2012-03-08 22:38:20,586 [INFO ] - Server Start : 192.168.1.11
2012-03-08 22:38:29,755 [INFO ] - ControlThink.ZWave Version: 1.3.0.23
2012-03-08 22:38:29,755 [INFO ] - .NET Framework: 2.0.50727.5448


This is the line where it established communication with my THinkStick...

Code: Select all
2012-03-08 22:38:14,421 [INFO ] - ZWave: Controller Connected! HomeId - 3668489476


Also you aren't running ThinkEssentials at the same time are you? You can't have two apps connected to the ThinkStick at once.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11062
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: ZWave Commander Not Showing Any Devices

Postby Josh42 » Wed Mar 28, 2012 2:29 pm

Also you aren't running ThinkEssentials at the same time are you? You can't have two apps connected to the ThinkStick at once.


That was the problem!

So how do I program scenes and zones using ZWave Commander? It didn't seem to import mine from ThinkEssentials.

Best,

Josh
Josh42
 
Posts: 2
Joined: Tue Mar 27, 2012 6:27 pm

Re: ZWave Commander Not Showing Any Devices

Postby Melloware » Wed Mar 28, 2012 6:44 pm

So Zones you just set up in the ZC UI. As for Scenes those are stored inside your devices if you have the proper devices by a Scene ID which you can get out of THinkEssentials like 10.

You can read more about it here:

http://forum.melloware.com/viewtopic.php?f=15&t=8683

This guy created another app just to support scenes. I have helped him support and donated my code to him so hopefully I will switch from having Zwave Commander EXE to just using zVirtualScenes.

http://forum.melloware.com/viewtopic.php?f=15&t=9142
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11062
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA


Return to Lightswitch/ZWave Commander

Who is online

Users browsing this forum: No registered users and 1 guest