[SOLVED] DLL is found when running from Netbeans

Feature Requests, Comments, Bugs, and Suggestions on the JIntellitype Java API.

[SOLVED] DLL is found when running from Netbeans

Postby iffamies » Thu Dec 29, 2011 4:30 am

So I'm having this strange-ish problem (that didn't exist 3 days ago! :x):

- I run my application using JIntellitype from Netbeans, it finds the DLL correctly etc
- However if I run my application like I normally would, it can't find the DLL

From Netbeans:
We need to debug JIntellitype handling:true and library location: C:\Users\iffamies\JImgur\dll\x64\JIntellitype.dll, thats it!

From another place:
Thu Dec 29 11:20:43 EET 2011 --- INFO --- [JImgur] We need to debug JIntellitype handling:false and library location: C:\Users\iffamies\JImgur\RELEASE\dll\x64\JIntellitype.dll, thats it!
Thu Dec 29 11:20:43 EET 2011 --- SEVERE --- [JImgur] Problem initializing JIntellitype:com.melloware.jintellitype.JIntellitypeException: Could not load JIntellitype.dll from local file system or from inside JAR

And as you might've noticed I'm on a 64-bit OS.
iffamies
 
Posts: 3
Joined: Thu Dec 29, 2011 4:24 am

Re: DLL is found when running from Netbeans, but not normally

Postby Melloware » Thu Dec 29, 2011 8:39 am

It means it can't find the DLL. Have you tried placing it in C:\Windows\System or the DLL should reside in the same directory from where you are executing the Java command.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11056
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: DLL is found when running from Netbeans, but not normally

Postby iffamies » Thu Dec 29, 2011 10:19 am

Yeah, I know it can't find the DLL. I've tried placing it to System and the same dir as the jar. It worked before having it next to the jar but now it refuses to do so. And as I said, it works when running the project from NEtbeans
iffamies
 
Posts: 3
Joined: Thu Dec 29, 2011 4:24 am

Re: DLL is found when running from Netbeans, but not normally

Postby Melloware » Thu Dec 29, 2011 10:40 am

iffamies wrote:Yeah, I know it can't find the DLL. I've tried placing it to System and the same dir as the jar. It worked before having it next to the jar but now it refuses to do so. And as I said, it works when running the project from NEtbeans


That is because Netbeans is adding it to the classpath. When running outside of Netbeans you must have changed where your Java command is being executed from.

This guy had the same issue and got it resolved.

http://forum.melloware.com/viewtopic.php?f=4&t=9522
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Melloware Inc.
http://www.melloware.com
=-=-=-=-=-=-=-=-=-=-=-=-=-=-
User avatar
Melloware
Site Admin
 
Posts: 11056
Joined: Thu Dec 01, 2005 10:24 pm
Location: Philadelphia, Pennsylvania USA

Re: DLL is found when running from Netbeans, but not normally

Postby iffamies » Thu Dec 29, 2011 5:49 pm

Yeah, well. This issue solved itself. Guess it was a temp. issue... thank
iffamies
 
Posts: 3
Joined: Thu Dec 29, 2011 4:24 am


Return to JIntellitype

Who is online

Users browsing this forum: No registered users and 1 guest